[Jde-dev] error al compilar 4.3 en ubuntu 10.04

Roberto Calvo rocapal en libresoft.es
Mar Mayo 4 17:37:02 CEST 2010


El mar, 04-05-2010 a las 17:26 +0200, Eduardo Perdices escribió:
> Hola, ya hemos probado a compilar con lo que hay en el trunk y parece 
> que va bien, quitando algunos drivers y schemas.
> 
> He tenido que hacer el configure con:
> 
> ./configure --disable-drivers-firewire --disable-drivers-evi 
> --disable-schemas-recorder --with-player=/usr

Sip, de hecho siempre que te bajes el trunk y lo tengamos paquetizado,
echale un ojo al debian/rules, que ahí viene el configure con el que
está pensando que se hagan los paquetes debian. En este caso:

./configure $(CROSS) --prefix=/usr --with-player=/usr/
--disable-drivers-firewire --disable-drivers-x10
--disable-schemas-x10_controller --disable-schemas-opengl_viewer
--disable-schemas-recorder --disable-schemas-myschema --mandir=\
$${prefix}/share/man --infodir=\$${prefix}/share/info 


> Porque la ruta del player no la encontraba bien y los otros no los 
> compilaba (el recorder creo que sigue fallando el xforms).
> 
> Luego faltaban las librerías libhighgui-dev y libssl-dev en la 
> compilación, que el ./configure no se ha quejado.
> 
> Y con esto, puede verse el resultado en la imagen adjunta, con un schema 
> de xforms y otro de gtk.

Vamos hombre!! y porque se me queda a mi congelado al arrancar ...grrrr!
Me alegro de que funcione ya bien!! De hecho, podrías hacer un
dpkg-buildpackage -us -uc y así teníamos los paquete debian para esa
ubuntu (no hace falta que montes chroot ni nada).

un saludete!

> 
> Saludos.
> 
> 
> Roberto Calvo wrote:
> > He subido unos cambios al subversion, para que compile jderobot:
> >
> >  * He quitado la comprobación de glcanvas.h porque no se porque falla al
> > compilar. Luego en la compilación normal no falla ¿será un bug?
> >  * He cambiado un include en trunk/schemas/opengldemo/opengldemo.c
> >  * He cambiado algunos *.fd porque la nueva versión del fdesign los
> > decimales son 0.0 y no 0,0.
> >  * He añadido la estructura correcta a debian/control, sino se quejaba.
> >
> > Me ha compilado todo bien, generado los paquetes debian (4.3.1) bien y
> > puedo instalarlo (hablo de Debian SID), pero es incapaz de lanzar
> > ninguna interfaz gráfica, da igual es esquema que sea, se queda
> > bloqueado. ¿A alguien más os pasa? Me resulta raro que una versión que
> > se está utilizando falle en algo tan básico, no?
> >
> > Eduardo, Sara, probar ahora a compilar en ubuntu y me decis si tenéis
> > problemas.
> >
> > un saludete!!
> >
> > El lun, 03-05-2010 a las 17:22 +0200, Eduardo Perdices escribió:
> >   
> >> Hola,
> >>
> >> no lo hemos llegado a probar, porque estábamos intentando compilar todo 
> >> para hacer el paquete debian. En principio deberían funcionar, aunque 
> >> nunca se sabe...
> >>
> >> Saludos.
> >>
> >> Luis Miguel López Ramos wrote:
> >>     
> >>> Hola!
> >>>
> >>> Con el apaño, los esquemas que usan glade y no xforms, ¿funcionan
> >>> bien? Lo digo por pensármelo antes hacer el upgrade (justo lo iba a
> >>> hacer hoy :P)
> >>>
> >>> Ánimo con la migración
> >>> LuisMi
> >>>
> >>> El día 3 de mayo de 2010 12:58, Sara Marugan <smarugan en gsyc.es> escribió:
> >>>   
> >>>       
> >>>> Hola,
> >>>>
> >>>> Edu y yo estamos compilando la 4.3 para generar un nuevo paquete para la
> >>>> nueva ubuntu, ya que las dependencias han cambiado.
> >>>>
> >>>> Nos hemos encontrado un error en un archivo de cabecera al ejecutar
> >>>> ./configure:
> >>>>
> >>>> /configure: error: in `/home/robotica/tmp/jderobot-4.3.0':
> >>>> configure: error: --enable-schemas-opengldemo was given, but there was
> >>>> errors: , glcanvas.h not found
> >>>> See `config.log' for more details.
> >>>>
> >>>> /Hemos comprobado en el log que lo encuentra pero no compila.
> >>>> Comparándolo con el /glcanvas.h de la versión 9.10 /hemos visto que ha
> >>>> cambiado de ruta y el contenido del archivo.
> >>>> Al probar el apaño (palabra preferida de Edu) de copiar el antiguo
> >>>> /glcanvas.h /en el nuevo ubuntu ya no ha dado el error. Sin embargo los
> >>>> schemas que utilizan xforms no compilan bien. Creemos que ha cambiado
> >>>> xforms y ya no pueden compilar.
> >>>>
> >>>> Nosotros lo dejamos.
> >>>>
> >>>> Un saludo!
> >>>> /
> >>>>
> >>>> /
> >>>> _______________________________________________
> >>>> Jde-developers mailing list
> >>>> Jde-developers en gsyc.es
> >>>> http://gsyc.escet.urjc.es/cgi-bin/mailman/listinfo/jde-developers
> >>>>
> >>>>     
> >>>>         
> >>> _______________________________________________
> >>> Jde-developers mailing list
> >>> Jde-developers en gsyc.es
> >>> http://gsyc.escet.urjc.es/cgi-bin/mailman/listinfo/jde-developers
> >>>   
> >>>       
> >> _______________________________________________
> >> Jde-developers mailing list
> >> Jde-developers en gsyc.es
> >> http://gsyc.escet.urjc.es/cgi-bin/mailman/listinfo/jde-developers
> >>     
> >
> >   
> 
> _______________________________________________
> Jde-developers mailing list
> Jde-developers en gsyc.es
> http://gsyc.escet.urjc.es/cgi-bin/mailman/listinfo/jde-developers

-- 
Roberto Calvo Palomino          | Libre Software Engineering Lab (GSyC)
Tel: (+34) 91 488 85 23         | Universidad Rey Juan Carlos
rocapal en libresoft.es            | Edif. Departamental II - Despacho 116
http://libresoft.es/            | c/Tulipán s/n 28933 Móstoles (Madrid)

GPG-KEY: http://gsyc.es/~rocapal/rocapal.gpg
------------ próxima parte ------------
Se ha borrado un mensaje que no está en formato texto plano...
Nombre     : no disponible
Tipo       : application/pgp-signature
Tamaño     : 198 bytes
Descripción: Esta parte del mensaje =?ISO-8859-1?Q?est=E1?= firmada
 digitalmente
Url        : http://gsyc.escet.urjc.es/pipermail/jde-developers/attachments/20100504/48fd861e/attachment.pgp 


More information about the Jde-developers mailing list